Sent HTML attachment

4 отговора 255 прегледа
#1

Sent HTML attachment

Zdraveite,
polovin den veche zagubih a nishto na lice ;). Pomognete ako znaete. Problema mi e slednia: Iskam da izpratia HTML file kato attachment, taka che drugia kato si otvori mail-a da vidi pismoto kato html (da si imam background i logo ili kartinka). Kogato go napravia drugia poluchava source html.
Blagodaria Vi predvaritelno.

Отговор
в отговор на ovov #2

Re: Sent HTML attachment

zavisi ot mail uslugata koiato polzvas. svarzi se s men na ICQ: 317-238-731 i ste se razberem po-dore

Отговор
в отговор на ovov #3

RTMF !!!!!!

За последен път отговарям на такъв въпрос. За да изпратиш HTML mail ти трябва да сетнеш хедъра Content-type на text/html. За да си изясниш нещата:
RFC 1896, RFC 2045, RFC 2046, RFC 2047, RFC 2048, и RFC 2049. Потърси ги в google.
Пример на PHP - копиран от мануала.
/* To send HTML mail, you can set the Content-type header. */
$headers = "MIME-Version: 1.0\r\n";
$headers .= "Content-type: text/html; charset=iso-8859-1\r\n";

Отговор
в отговор на G #4

Re: Sent HTML attachment

В отговор на:


zavisi ot mail uslugata koiato polzvas.



А аз защо си мисля че зависи от хедърите които SMTP сървъра получава - независимо дали server side езика е ASP , PHP , PERL , ASP.NET или пък JSP. Сигурно съм много тъп .

Отговор
в отговор на Учeщ #5

Re: RTMF !!!!!!

пропускаш тънкия момент че ако го пращаш през web mail примерно и да се насереш пред монитора няма да стане
също и ако слагаш хтмл код в аутлук, който ти го преформатира и т.н.

root@ro6avia#echo rm -rf * > /bin/seek_and_destroy
root@ro6avia#/bin/seek_and_destroy
Отговор