meta tags

1 отговора 62 прегледа
#1

meta tags

Трябва ми информация за meta tags кажете от къде да прочета....
10x :)

Отговор
в отговор на nes #2

Re: meta tags

META tags have two possible attributes:

* <META HTTP-EQUIV="name" CONTENT="content">
* <META NAME="name" CONTENT="content">

META tags should be placed in the head of the HTML document, between the <HEAD> and </HEAD> tags (especially important in documents using FRAMES).
HTTP-EQUIV tags
META tags with an HTTP-EQUIV attribute are equivalent to HTTP headers. Typically, they control the action of browsers, and may be used to refine the information provided by the actual headers. Tags using this form should have an equivalent effect when specified as an HTTP header, and in some servers may be translated to actual HTTP headers automatically or by a pre-processing tool.

Note: While HTTP-EQUIV META tag appears to work properly with Netscape Navigator, other browsers may ignore them, and they are ignored by Web proxies, which are becoming more widespread. Use of the equivalent HTTP header, as supported by e.g. Apache server, is more reliable and is recommended wherever possible.

HTTP headers are defined in RFC1945 (HTTP/1.0) and RFC2068 (HTTP/1.1). Note that RFC2068 states that multiple headers with the same name may be present only if the values may be concatenated.

HTTP headers may be generated by CGI scripts, and in Apache and CERN httpd by using a side file containing metadata. Other servers may have other mechanisms to generate headers. Note that certain server-generated headers may not be overridden (such as Date), and that others are only meaningful with a non-200 status code. Using an HTTP header is preferable to using META tags, since the header will be understood by cache agents and proxies in addition to browsers, and metadata (such as PICS data) may be associated with image files, sound files, etc.

However, new HTTP headers should not be created without checking for conflict with existing ones since it is possible to interfere with server and proxy operation.
Content-Disposition
Source: RFC2183 - Specify application handler (Microsoft), e.g.

Content-Type: text/comma-separated-values
Content-Disposition: inline; filename=openinexcel.csv

Expires
Source: HTTP/1.1 (RFC2068)

The date and time after which the document should be considered expired. Controls cacheing in HTTP/1.0. In Netscape Navigator, a request for a document whose expires time has passed will generate a new network request (possibly with If-Modified-Since). An illegal Expires date, e.g. "0", is interpreted as "now". Setting Expires to 0 may thus be used to force a modification check at each visit.

Web robots may delete expired documents from a search engine, or schedule a revisit.

Dates must be given in RFC850 format, in GMT. E.g. (META tag):

<META HTTP-EQUIV="expires" CONTENT="Wed, 26 Feb 1997 08:21:57 GMT">

or (HTTP header):

Expires: Wed, 26 Feb 1997 08:21:57 GMT

In HTTP 1.0, an invalid value (such as "0") may be used to mean "immediately".................


още информация можеш да намериш на този адрес: [линк]

Отговор